25/04/2017

Cisco – ASR 920 VPLS – BGP signaled

VPLS mit BGP signaling

Wir haben drei ASR 920. Der oben ASR am Bild (ASR-920-4SZ-A) ist ein P Router, die anderen beiden (ASR-920-24SZ-M) sind PEs. IGP und MPLS laeuft bereits. Die beiden Catalyst 3560 und das MikroTik RouterBOARD sind „Hosts“ im VPLS.

ASR 920 – PE1:

router bgp 65432
 neighbor 10.1.1.3 remote-as 65432
 neighbor 10.1.1.3 update-source Loopback0
 !
 address-family l2vpn vpls
  neighbor 10.1.1.3 activate
  neighbor 10.1.1.3 send-community extended
  neighbor 10.1.1.3 suppress-signaling-protocol ldp
 exit-address-family


l2vpn vfi context VPLS002
 vpn id 301
 autodiscovery bgp signaling bgp
  ve id 1301
  rd 1:301
  route-target export 1:301
  route-target import 1:301


bridge-domain 301
 member GigabitEthernet0/0/1 service-instance 1
 member GigabitEthernet0/0/13 service-instance 1
 member vfi VPLS002


interface GigabitEthernet0/0/1
 no ip address
 negotiation auto
 service instance 1 ethernet
  encapsulation default
  l2protocol forward


interface GigabitEthernet0/0/13
 no ip address
 negotiation auto
 service instance 1 ethernet
  encapsulation default
  l2protocol forward

 
ASR 920 – PE2:

router bgp 65432
 neighbor 10.1.1.2 remote-as 65432
 neighbor 10.1.1.2 update-source Loopback0
 !
 address-family l2vpn vpls
  neighbor 10.1.1.2 activate
  neighbor 10.1.1.2 send-community both
  neighbor 10.1.1.2 suppress-signaling-protocol ldp


l2vpn vfi context VPLS002
 vpn id 301
 autodiscovery bgp signaling bgp
  ve id 2301
  rd 1:301
  route-target export 1:301
  route-target import 1:301


bridge-domain 301
 member GigabitEthernet0/0/13 service-instance 1
 member vfi VPLS002


interface GigabitEthernet0/0/13
 no ip address
 negotiation auto
 service instance 1 ethernet
  encapsulation default
  l2protocol forward

 

Das schaut dann so aus:

Router(config)#do sh bgp l2vpn vpls all sum
BGP router identifier 10.1.1.2, local AS number 65432
BGP table version is 11, main routing table version 11
4 network entries using 672 bytes of memory
4 path entries using 384 bytes of memory
3/3 BGP path/bestpath attribute entries using 480 bytes of memory
3 BGP extended community entries using 120 bytes of memory
0 BGP route-map cache entries using 0 bytes of memory
0 BGP filter-list cache entries using 0 bytes of memory
BGP using 1656 total bytes of memory
BGP activity 6/2 prefixes, 6/2 paths, scan interval 60 secs

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
10.1.1.3        4        65432      65      62       11    0    0 00:46:36        2
Router(config)#

 
Und so:

Router(config)#do sh l2vpn vfi name VPLS002
Legend: RT=Route-target, S=Split-horizon, Y=Yes, N=No

VFI name: VPLS002, state: up, type: multipoint, signaling: BGP
  VPN ID: 301, VE-ID: 1301, VE-SIZE: 10
  RD: 1:301, RT: 65432:301, 1:301,
  Bridge-Domain 301 attachment circuits:
  Pseudo-port interface: pseudowire100005
  Interface          Peer Address    VE-ID  Local Label  Remote Label    S
  pseudowire100006   10.1.1.3        2301   220          337             Y

Router(config)#

 

Sicht von einem der drei „Hosts“: