12/10/2016

Cisco – Multicast Hardware Lab

 

Behaupte ja nach wie vor dass ich mich mit Multicast nicht auskenne (zu meiner Schande), aber hab heute wieder mal rumspielen koennen und das kam dabei raus (ich hoff ich hab jetzt nicht schon wieder was vergessen):

multicast

Ein Cisco DCM stellt mir einen UDP Stream auf 224.10.51.1:5000 zur Verfuegung. Von dem DCM geht ein Trunk zu einem alten Cisco 7201. Dieser macht einmal das Multicaast Routing und ausserdem das Routing ins Internet (hier mal ignoriert). Von dem 7201 geht ein Trunk auf einen Cisco ME 3400G-2CS-A Switch, welcher das FTTH Netz simuliert. Von diesem geht wiederum ein Trunk auf einen Cisco 892FSP, welcher das CPE sein soll.

 

Die Config auf dem Cisco 7201 sieht so aus (reduziert auf das Wichtigste):

ip multicast-routing
ip cef
!
interface GigabitEthernet0/0
 no ip address
 media-type rj45
 speed auto
 duplex auto
 negotiation auto
!
interface GigabitEthernet0/0.171
 description TRUNK zum DCM
 encapsulation dot1Q 171
 ip address 172.16.171.160 255.255.255.0
 ip broadcast-address 172.16.171.255
 ip pim sparse-mode
!
interface GigabitEthernet0/1
 description TRUNK ins simulierte FTTH Netz
 no ip address
 media-type rj45
 speed auto
 duplex auto
 negotiation auto
!
interface GigabitEthernet0/1.170
 description IPTV Multicast VLAN
 encapsulation dot1Q 170
 ip address 10.255.170.254 255.255.255.0
 ip broadcast-address 10.255.170.255
 ip pim sparse-mode
!
interface GigabitEthernet0/1.328
 description Internet VLAN
 encapsulation dot1Q 328
 ip address 10.255.100.254 255.255.255.0
 ip broadcast-address 10.255.100.255
!
ip pim rp-address 10.255.170.254

 

Die Config am ME3400 war ziemlich spartanisch (ebenfalls reduziert):

vlan 170,328
!
interface GigabitEthernet0/3
 port-type nni
 switchport mode trunk
!
interface GigabitEthernet0/4
 port-type nni
 switchport mode trunk

 

Die Config am Cisco 892FSP, sprich dem CPE sah ca so aus:

vrf definition IPTV
 ipv4 multicast multitopology
 rd 1:170
 !
 address-family ipv4
 exit-address-family
 !
 address-family ipv4 multicast
 exit-address-family
!
ip dhcp pool LAN
 network 192.0.2.0 255.255.255.0
 default-router 192.0.2.254
 dns-server 8.8.8.8
!
ip dhcp pool IPTV
 vrf IPTV
 network 172.31.31.0 255.255.255.0
 default-router 172.31.31.254
!
ip multicast-routing
ip multicast-routing vrf IPTV
ip cef
!
vlan 100
 name IPTV LANseitig
!
vlan 170
 name IPTV
!
vlan 300
 name Internet LANseitig
!
vlan 328
 name Internet
!
interface GigabitEthernet0
 switchport access vlan 100
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet1
 switchport access vlan 300
 no ip address
 spanning-tree portfast
!
interface GigabitEthernet8
 description UPLINK
 no ip address
 duplex auto
 speed auto
!
interface GigabitEthernet8.170
 encapsulation dot1Q 170
 vrf forwarding IPTV
 ip address 10.255.170.1 255.255.255.0
 ip pim sparse-mode
 ip nat outside
 ip virtual-reassembly in
!
interface GigabitEthernet8.328
 encapsulation dot1Q 328
 ip address 10.255.100.1 255.255.255.0
!
interface Vlan100
 description IPTV LANseitig
 vrf forwarding IPTV
 ip address 172.31.31.254 255.255.255.0
 ip pim sparse-mode
 ip nat inside
 ip virtual-reassembly in
!
interface Vlan300
 description Internet LANseitig
 ip address 192.0.2.254 255.255.255.0
!
ip pim vrf IPTV rp-address 10.255.170.254
ip nat inside source list 1 interface GigabitEthernet8.170 vrf IPTV overload
ip route 0.0.0.0 0.0.0.0 10.255.100.254
ip route vrf IPTV 0.0.0.0 0.0.0.0 10.255.170.254
!
!
access-list 1 permit 172.31.31.0 0.0.0.255

 

Das MacBook Pro war somit ohne NAT (mit public IPv4) ganz normal online und in der Global VRF zu Hause. Die Settop Box war in der IPTV VRF und konnte den DCM Stream problemlos sehen/empfangen. Statt einer VRF ginge zB auch PBR, damit wir den IPTV Traffic ueber VLAN 170 schicken, aber die VRF Variante ist vermutlich eh schoener…

 

Das hier war ein ziemlicher Quick and Dirty Beitrag, somit hoffe ich nicht dass ich irgendwas zuwenig aus der CLI kopiert habe oder hier versehentlich weggeloescht. Angaben also wie immer ohne Gewaehr đŸ˜‰